CNY70 en Basic Stamp 2

Todos sobre robots creados de forma casera.
Responder
dchamo79
Miembro Nuevo
Miembro Nuevo
Mensajes: 1
Registrado: 28 Nov 2015, 10:44

CNY70 en Basic Stamp 2

Mensaje por dchamo79 » 28 Nov 2015, 10:49

Buenas noches a todos. Antes de nada decir que soy un informático que intenta a marchas forzadas aprender algo de robótica y estoy comenzando, por lo que ruego tengáis algo de paciencia conmigo :( .
El tema es que tengo una basic stamp homework board y pasadas las primeras prácticas típicas he llegado a algo más complicado que seguro que a vosotros os resultará fácil. Estoy probando un sensor de infrarrojos "CNY 70" para el cual he tenido que leer mucho hasta llegar al circuito que adjunto en la foto. Por si no se ve bien en la imagen son dos resistencias, la del cátodo(cny 70) es de 10K y la del emisor(cny 70) es de 100 ohmios. El deco es un CD4511BE. Resulta que ejecutando el siguiente simple código en PBASIC:

' {$STAMP BS2}
' {$PBASIC 2.5}
PAUSE 1000
DO

DEBUG CRSRXY,0,3,"P6 = ",BIN1 IN6

PAUSE 100

LOOP

Intento tan sólo que el sensor me devuelva 1 o 0 en función de si tiene o no delante un objeto pero sólo manda "1" al IN6.

Mi pregunta es, veis algo que esté mal? Están bien las resistencias? Estoy usando corréctamente el CD4511BE?

Agradezco muchísimo de antemano vuestra ayuda porque estoy complétamente atascado después de haber probado hasta donde mis conocimientos dan.

Un saludo a tod@s
Adjuntos
800ancho.jpg
(201.29 KiB) No descargado aún

Responder